24.11.2006

Making TextIndexNG3 compatible with Plone users

Some Plone users had a hard-time in the past with the configuration of TextIndexNG3. Since the out-of-the-box installation should be running on a bare Zope system, it has been impossible to ship TextIndexNG3 with a configuration that would work out-of-the-box with Plone. Userd has to edit a configure.zcml file in order to register adapters for Plone content-types properly. This caused unnecessary headaches for users and myself. The upcoming TextIndexNG V 3.2.0 release will auto-configure all adapters properly (at least for the default Plone content-types) and it will no longer be necessary to touch any configure.zcml file. This will hopefully help avoiding the need to explain how to edit XML files :-) This auto-configuration feature currently only works with Zope 2.10..have to check how to backport the functionality back to at least Zope 2.9.